• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Couple of questions (regarding markers and TAX)


Author Message
roel018
Roel
Multishop newbie
Topic creator
registered since: 21.02.2014
Posts: 1
Hi,

I'm working on installing Multishop V3 on my TYPO3 4.7 installation. So far everything's working good, except two things.

1) While I have set up different TAX Rule Groups, different TAX percentage values, and assigned these TAX values to different countires, when adding a new product, the EXCL/INCL TAX prices always are identical - where you would expect that when you fill out the Excl. TAX price, the Excl. TAX price would automatically be calculated and displayed. This is not the case, no matter what I try.

2) In a simple template file, for example categories_listing.tmpl, when I add a predefined marker like for instance ###CUSTOMER_ID###, this exact phrase gets rendered, it's not parsed into the actual value. Same happens when I use the CMS feature of the front-end admin. When I add such a marker into the text editor after adding a new page, the exact phrase, incl. ### characters, gets rendered, not the actual value. What am I doing wrong?

Thanks for any help about these topics icon_smile.gif

Best regards,
Roel
Written on: 21. 02. 2014 [08:50]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Think the TAX issue is because your shop's tt_address record has no country. You have to edit the tt_address record and define the country inputfield. Example value: germany.

Creating the shop tt_address record
----------------------------------------------
Also make sure the constant editor is configured properly. This line you have to configure:

plugin.multishop.tt_address_record_id_store = XXX

Where XXX is the id of the tt_address record.

More info here:

http://docs.typo3.org/typo3cms/extensions/multishop/ExtMultishop/InstallationInstructions/Index.html


(make sure you update to Multishop V3, cause V2 is no longer supported.)


That is because the markers you want to use are meant for different sections. The categories_listing.tmpl has no marker ###CUSTOMER_ID###. That is only related to the e-mail order confirmation letter (and order paid letter, order status update letter etc).
Written on: 19. 07. 2014 [21:55]