• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Empty shop page


Author Message
Sunny
Sonja
Multishop newbie
Topic creator
registered since: 17.08.2011
Posts: 3
Hi,

yesterday I started testing your shop.

I followed the instructions in the video and in the manual:
- installed the extension from TER
- created the core shop page in the tree
- put the core plugin on this page
- included the root template in the root page and the core template in the core page
- created some user groups and users
- wrote the pids of the pages and the user groups in the root constants

In the FE I could log in with my newly created admin user. I imported some products and categories just the way you did it in the video.
But while you can see your imported products and categories on your core shop page afterwards, my shop page is still empty. All I see is the Powered by Typo3 Multishop logo, nothing else.
Did I forget anything? Do I need to add some more plugins on the core page? I understood that the core plugin is all I need to run the shop. Isn't this correct?
Do I need anything else? More pages in the tree?
Plz help me, I don't get it.

Thx in advance.
Sonja
Written on: 17. 08. 2011 [06:38]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Hard to say what is causing the blank page.

Please contact us on Skype -> typo3multishop so we can assist live.
Written on: 18. 08. 2011 [10:25]
Sunny
Sonja
Multishop newbie
Topic creator
registered since: 17.08.2011
Posts: 3
Me again. icon_wink.gif

I guess I found the solution. In the database table "tx_multishop_configuration" amongst others the entry containing the key "HOME_PRODUCTS_LISTING" was missing and therefore $ms['MODULES']['HOME_PRODUCTS_LISTING'] in core.php wasn't set. So the products listing template was never included.

After I imported the static configuration data again it's finally working and my blank page is gone. icon_smile.gif

I'm sure I had imported this static data during the installation process already. But I remember to have checked the database analyser afterwards and there were lots of confusing queries listed concerning multishop, as described <here>.
I'm afraid I was that stupid and truncated those configuration tables including the above mentioned entry. banghead.gif
I think you should fix this analyser issue, it's very dangerous, because the analyser tells you to truncate some tables, even fe_users. If one isn't cautious important data might be gone.
Written on: 19. 08. 2011 [10:07]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Hi Sunny,

Sometimes when installing the Plugin not all tables were created succesfully. I think that is the cause. We released this fix yesterday night in version 1.0.24. Please install it to make sure all the required tables are in place.
Written on: 23. 08. 2011 [08:13]