• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Error importing from cvs


Author Message
gertkh
Gert
Multishop newbie
Topic creator
registered since: 18.09.2013
Posts: 2
Hi

I am getteing this error every timne i import products from a CVS file

caller TYPO3\CMS\Core\Database\DatabaseConnection::sql_query
ERROR Duplicate entry '0-0' for key 'PRIMARY'
lastBuiltQuery INSERT INTO tx_multishop_products_description (language_id,products_id,products_meta_title,products_meta_description,products_meta_keywords,products_name,products_description,products_shortdescription,products_url) VALUES ('0','0','','','','Inverto SatCR multiswitch','Unicable multiswitch til serie forbindelse (Cascade).
Der kan på en enhed monteres op til 4 SatCR receivere, samt en konventionel universal receiver.
Enheden muliggør ligeledes at distribuere terrestrisk signal sammen med SatCR signalet.','Unicable multiswitch','')
debug_backtrace require(6.1.7/typo3/sysext/cms/tslib/index_ts.php),index.php#41 // TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController->INTincScript#204 // TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController->recursivelyReplaceIntPlaceholdersInContent#3406 // TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController->INTincScript_process#3428 // TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer->USER#3480 // TYPO3\CMS\Frontend\ContentObject\UserContentObject->render#904 // TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer->callUserFunction#55 // call_user_func_array#6441 // tx_multishop_pi1->admin_main# // require(typo3conf/ext/multishop/scripts/admin_pages/core.php),typo3conf/ext/multishop/pi1/class.tx_multishop_pi1.php#180 // require(typo3conf/ext/multishop/scripts/admin_pages/admin_import.php),typo3conf/ext/multishop/scripts/admin_pages/core.php#122 // TYPO3\CMS\Core\Database\DatabaseConnection->sql_query#1952 // TYPO3\CMS\Core\Database\DatabaseConnection->debug#988
Written on: 18. 02. 2014 [11:18]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
What I see is that products_id is 0 in the query. That means the insert query to the table tx_multishop_products failed.

Update to V3. if issue still exists report on the V3 forum:
https://www.typo3multishop.com/forum/list_topic/typo3-v3/
Written on: 24. 06. 2014 [09:38]