• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Initial products import


Author Message
axl
Axel
Multishop newbie
Topic creator
registered since: 01.09.2011
Posts: 3
Hello,
I'm currently testing Multishop and I'm really impressed.
I'd like to ask aquestion according the products import:
How can I import multiple attribut values, such as 3 different colors for one product? When doing it manually in the frontend it's working fine but how it has to be specified in an import csv file for instance?

thx

axl
Written on: 01. 09. 2011 [14:09]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
This can be done by splitting the import in several steps.

Step 1: create and import the product feed
For example this feed contains the following fields:

products id
products name
category
sub category
price

Import this feed like you normally do.

Step 2: create and import the products attribute feed
This feed contains the following fields:

products_id
option name
option value

On the importer columns mapping page make sure you enable the incremental checkbox. This will make sure that any previous option values (that are already existing in the database) won't be deleted.

Hope it helpes. Otherwise let me know and I will add a YouTube video for it.
Written on: 01. 09. 2011 [17:36]
axl
Axel
Multishop newbie
Topic creator
registered since: 01.09.2011
Posts: 3
OK, got it. And thanks for the quick reply, it works that way but only with 1 option for 1 product_id. That means (for the following example table) that only p001 is equipped with a Size dropdown containing 32,34,36,38 and only p004 has got a Color dropdown containing values red and green after import:

id option values
p001 Size 32
p001 Size 34
p001 Size 36
p001 Size 38
p002 Size 32
p002 Size 34
p002 Size 36
p003 Size 32
p003 Size 34
p003 Size 36
p004 Color red
p004 Color green
p005 Color red
p005 Color green

So I have to split again into several product_id import files or am I wrong?
The idea behind is to migrate data from an existing database in as less steps as possible...

thanks again and have a nice evening.

Axel
Written on: 01. 09. 2011 [19:34]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
That's odd.

Tomorrow we have planned to release our updates to TER. Give me one day so I can simulate your specific issue.

If I have the same issue I will fix it and include the fix in the next update.

Written on: 01. 09. 2011 [21:15]
parzival
Helge Farr
Multishop expert
registered since: 25.08.2011
Posts: 69
Hi Axl and Bas,

have the same problem with importing options and tried it
with splittig, but haven´t been successful.

Further more have problems with importing images in relation
of a csv file.

Situation: Have got a csv-file with about 700 products and a folder where all the related images are in. In csv-file the product images are named somewhat like this
productimage1.jpg

On my system I have created a folder .../fileadmin/multishop/images/...

Now all related images are in this folder on server. In addition I put the csv-file in the image-folder because there is no path in csv, only the imagename with file ending .jpg

Had been successful with the import by using the option: import from url by filling in: http://www. .de/fileadmin/multishop/images/productlist.csv

But only product name, price, VAT, short description and description were imported.

No Product ID, no options, no images.

Tried it with splitting, but no results. There is only a message per product: Your changes hav been adjusted. But no change had been adjusted and nothing has been added.

Hint: By expierience from multishop 1.0.22 and 1.0.24 I have removed all watermark configurations in admin configuration panel, because with these configorations, it was not possible for me to upload and store a single productimage for a single product.

The import module is one of the most important features what drives me to multishop.

So hope you can help me to find out the reasons why this does not work.
Written on: 02. 09. 2011 [08:34]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Axl,

The bug that you have mentioned yesterday has been confirmed and I already fixed it. The update will be sent today. Feel free to subscribe to our Twitter (http://twitter.com/#!/typo3multishop) to know exactly when it's launched.

Parzival,

I can't confirm your watermarking issue. Perhaps some specific hosting environment issue, I can't say from here.

Please submit the PHP server errors that you get in the webserver error log or add us to your Skype to fix together (username: typo3multishop).

About the image paths. Relative paths are not yet supported, but full absolute paths are.

So instead of:
fileadmin/multishop/images/image.jpg

Define it as:
/var/www/vhosts/site.com/httpdocs/fileadmin/multishop/images/image.jpg

Let me know if helped!
Written on: 02. 09. 2011 [10:27]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Update has been released to TER. Takes couple of hours before it gets active.
Written on: 02. 09. 2011 [14:39]
parzival
Helge Farr
Multishop expert
registered since: 25.08.2011
Posts: 69
Hi Bas,

first, a big thank you for your fast reply once again and for your abvice concerning the picture import. I will test it tomorrow.

But have a problem with your advice, let´s say it better, not with the advice but with the provided cvs file and picture folder, my customer sent to me and for what he has payed for and got delivered these files by a company what is distributing these products, he wants to sell on his own account.

I know, if I would input the direct path to each image, this would probably work. But in this case, there are nearly 700 products with about 1300 images.

As discribed, in the csv file the images are named by filename, like "productimageblabla" and file ending like ".jpg". single relatet to each product. confuguring the file path for each picture in csv would last days, even if I would do that by copy and paste 1300 times. I think that´s against the sense and purpose of importing product data.

the best would be a solution where the imported csv could fetch the related images and import it, if the csv is placed in the same folder. This is what I have tried without success.

From another extension, what I am working with, I know, it is possible to upload prices, products and multiple images etc. within one file, I know, it is possibele. But the mentioned extension is using only xml files for this purpose and is made for realty avertising.

Think xml files are more sophisticated for that purpose. But in this case this knowledge does not help.


Written on: 02. 09. 2011 [16:52]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Fair enough. I have added the feature and released version 1.0.30 to TER.

What you need to do is:

Edit your import task
On the image field press the "advanced settings" button, the aux field appears now on your screen. In this input field specify the full URL or the absolute path of the image folder that contains the images.

Example AUX value:

/var/www/site.com/myimagefolder

The importer will use this as prefix and adds a slash plus the image field value. So if the value of the image field would be "myimage.jpg" then the full path would be changed to:

/var/www/site.com/myimagefolder/myimage.jpg

I have attached a screenshot to make it more clear.

Let us know if it fixed your issue!

Attachment

Written on: 04. 09. 2011 [23:03]
parzival
Helge Farr
Multishop expert
registered since: 25.08.2011
Posts: 69
Hello Bas,

first thank you for your efforts on the issue "image import".

unfortunately I have not been successful until yet.

I tried it with:

/var/www/mysite.de/fileadmin/multishop/images

and

http://www.mysite.de/fileadmin/multishop/images

But no way. No immage has been added to a product.

Hope it is not a matter of the new version in TER what now depends on Typo3 4.5.2, while I am still using V 4.4.8.

I have uploaded and installed multishop 1.0.30 and ignored the dependecy of 4.5.

At this moment I do not like to go on 4.5 because on last Update to 4.4... I have had lots of troubles to get all installed extensions (there are a lot) work properly again.

Written on: 05. 09. 2011 [08:35]