• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Installation Not Possible


Author Message
annadawiesn
anna
Multishop newbie
registered since: 23.04.2012
Posts: 3
Hello Bas,
thanks for your reply. This morning I managed it to install. At this moment I better say, the add icon turns into green. I have manually imported the db. then i have uploaded your version from yesterday via ftp extracted on localhost. Then I have unchecked the update options where the TER asks me if I wish to update 2 more db tables. The native installation via TER with the refactored source unfortunately din't worked either. When I try to update the missing tables and static data the installation breaks and the following error comes up:

ERROR: Query could not be parsed: "SQL engine parse ERROR: Field type unknown in parseFieldDef()!: near "configuration_value (configuration_value) ) ENGINE"". Query: "CREATE TABLE tx_multishop_configuration ( id int(5) NOT NULL auto_increment, configuration_title varchar(64) NOT NULL default '', configuration_key varchar(64) NOT NULL default '', configuration_value text, description varchar(255) NOT NULL default '', group_id int(5) NOT NULL default '0', sort_order int(5) default '0', last_modified int(11) default '0', date_added int(11) default '0', use_function varchar(255) default '', set_function varchar(255) default '', depend_on_configuration_key varchar(64) default '', PRIMARY KEY (id), KEY configuration_key (configuration_key), KEY configuration_group_id (group_id), KEY sort_order (sort_order), KEY configuration_title (configuration_title), KEY admin_search (configuration_title,configuration_key), FULLTEXT configuration_value (configuration_value) ) ENGINE=MyISAM;"

I have then manually inserted the missing tables and the static data via phpmyadmin. that worked. weird, isn't it? icon_wink.gif Now I'm in tense getting the rest up to work.

greets,
annadawiesn
Written on: 26. 04. 2012 [09:56]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
The problem is we work with FULLTEXT indexes for faster searching. I'm aware of the fact that this is specific type for MySQL and TYPO3 extension manager will never support it. So in V3 this will not be an issue anymore.

So you have it working with Eaccelerator enabled? I hope so cause in the beta version that I send to you is having some tweaks that I believe is fixing the problem Eaccelerator.
Written on: 12. 05. 2012 [00:42]