• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

MultiSafepay send wrong values to the payment provider


Author Message
info@data-dienste.de
Eduard Müller
Multishop experienced
Topic creator
registered since: 16.01.2016
Posts: 5
Hello,

using MultiSafepay i do have a problem: The typo3 extension sends wrong values for the parameters "country" and "locale".

The multisafepay.com Technical Support wrotes:

Are you using the JSON API or XML?
Upon creating a transaction you send us the proper data needed to initialize a transaction.
With this data, wheter it is JSON or XML, you must provide the customers country and locale code.
For example: the "country" is used to show the proper bankaccount, addresses or phonenumbers. And the "locale" determines the spoken language.

All I can see is that your system provides the country and locale the incorrect way, for country you use "germany" and for locale it was "de".

For JSON this should be:
"country":"de"
"locale":"de_DE"

For XML this should be:
<country>de</country>
<locale>de_DE</locale>


But where can i configure that (and how can i debug that)?

Used software:
- TYPO3 6.2.15
- Multishop multishop 3.1.1 (BVB Media BV)
- Multishop MultiSafepay multishop_multisafepay 1.0.5 (BVB Media BV)
https://www.typo3multishop.com/supported-payment-service-providers/multisafepay/
Date last tested: 2014-06-25. Multishop version: 3.0.4.


Kind regards,
E. Müller
Written on: 25. 03. 2016 [10:07]
info@data-dienste.de
Eduard Müller
Multishop experienced
Topic creator
registered since: 16.01.2016
Posts: 5
I found the wrong part in the Typo3-Extension "Multishop MultiSafepay".The hints from the multisafepay.com Technical Support led me:[quote]All I can see is that your system provides the country andlocale the incorrect way, for country you use "germany" and forlocale it was "de".[/quote]In the shop formular, you can choose your country and there you can find [quote][/quote], which is seemingly send to the payment provider.But unfortunately the payment provider expect "DE" and not "germany".The relevant PHP code i found in the file typo3conf\ext\multishop_multisafepay\class.multishop_payment_method.php[quote]...$msp->customer["locale"]="nl";$msp->customer["country"]=trim($order["billing_country"]);...[/quote]I changed that to[quote]$msp->customer["locale"]="de_DE";$msp->customer["country"]="DE";[/quote]=> And now, the payment provider shows me a german bank account (not the netherland bank account).More information you can find at https://github.com/MultiSafepay/PHP/blob/master/controllers/klarnaController.php and https://www.multisafepay.com/documentation/doc/API-Reference/

[This article was edited 1 times, at last 04.04.2016 at 10:01.]
Written on: 04. 04. 2016 [09:58]