• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Multishop Updates some annoying issues


Author Message
parzival
Helge Farr
Multishop expert
Topic creator
registered since: 25.08.2011
Posts: 69
Hi forum,

for multishop there are many updates. Generally this is a good thing, because it shows that one is working constantly on this extension to make things bettter.

But there are some issues, what are really annoying:

1. After every update one gets the default configuration on configuration panel and has to customise the default settings again and again.
2. In addition products are not in the same chronological order as before update.

A small bug seems to be, that by changing the price setting to:
"show prices with and without VAT" the currency symbol, for example € disappears. If going back to default setting it remains vanished.

Hope this can be solved with one of the next updates.
Written on: 30. 08. 2011 [08:08]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
When you install a newer version the TYPO3 system asks you to also import the static data.

Just disable the checkboxes in front of each specified table and you won't lose your settings and be able to update without a hazzle.

Written on: 30. 08. 2011 [18:01]
parzival
Helge Farr
Multishop expert
Topic creator
registered since: 25.08.2011
Posts: 69
Bas,

thank you for the tip for further updates. but what´s about
the vanishing of the currency symbol. by changing the price
from VAT included, to with and without VAT ??
Written on: 31. 08. 2011 [07:02]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Will be fixed in the next update.

If you can adjust code yourself:

open typo3conf/ext/multishop/scripts/front_pages/includes/products_listing/grid.php

Adjust this:

PHP
$final_price.='<div class="price_excluding_vat">'.$this->pi_getLL('excluding_vat').' '.mslib_fe::Money2Cents($product['final_price']).'</div>';


To:

PHP
$content.='<div class="price_excluding_vat">'.$this->pi_getLL('excluding_vat').' '.mslib_fe::Money2Cents($product['final_price']).'</div>';


Written on: 01. 09. 2011 [17:55]
parzival
Helge Farr
Multishop expert
Topic creator
registered since: 25.08.2011
Posts: 69
Ok,

found out, that it is not the issue with VAT including or not, what makes the currency symbol vanish. It happens,
by changing the country iso code from Netherland to Germany.

This became evident by uninstalling and reinstalling multishop.
And though following your tips from the previous post, not to actualise the tables, by updating or reinstalling, there was no category and no product anymore in the shop. (No actualisation of tables). Acting against your tip, I did the actualisation of tables again. Result: I got all my categories and products back. But, the same as when updating, all customised configurations, including confirmation letters
were erased and I had to do the whole job again.

Hope there will be a satifying solution soon for this issue!


Written on: 02. 09. 2011 [07:03]
parzival
Helge Farr
Multishop expert
Topic creator
registered since: 25.08.2011
Posts: 69
Hello,

the issue with updating and reinstalling seems to be solved.

last time I forgot to disable these checkboxes in ext. manager:

Statische Daten importieren
tx_multishop_configuration Zeilen: 73 Tabelle bereits vorhanden!
tx_multishop_configuration_group Zeilen: 11 Tabelle bereits vorhanden!
tx_multishop_configuration_values Zeilen: 32 Tabelle bereits vorhanden!

at last update I disabled these checkboxes, and the change of configurations remained stored. thank you for the advice.

The disappearence of the currency symbol, I found out, has nothing to do with Vat included or not. It´s a matter of Country ISO Code. On every other ISO Code, except ISO for the Netherlands the Currecy Symbol disappears. For example France, Germany etc. I remain with ISO on the Country Code of the Netherland and it works. No difference on calculation and the currency symbol remains visible. Also the Vat percentage remains at 19 percen the same. May be the reason is, it comes from imported csv file. (Do not know the VAT percentages for the Netherlands 19% ? icon_smile.gif)

The importend thing for me is one can work with, so I look upon this issue for me as solved. The only question what remains is: For what reason one should have the possibility to change the ISO Country Code in configuration.
Have a nice weekend!


[This article was edited 1 times, at last 03.09.2011 at 15:17.]
Written on: 03. 09. 2011 [09:41]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
The ISO code is for deciding which TAX percentage the store should use. In the Netherlands we have 0%, 6% and mostly 19%.

If you change the ISO code to your country it should show your local tax.

This section is depending on the static_info_tax plugin and could be that it's missing some details. For example for the Netherlands it only has 19%, so we add the 6% manually to the static info tax table.

Which ISO country are you using? Then I can simulate your issue better.
Written on: 04. 09. 2011 [10:40]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
This issue has been resolved.
Written on: 14. 10. 2011 [20:06]