• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

No import possible


Author Message
RasLeemur
Jakob Kögel
Multishop experienced
Topic creator
registered since: 09.05.2014
Posts: 8
Hi there,

I'm trying to import a csv file from LX-Office and didn't succeed at all.
When I try to import the csv-file directly i am able to assign the collumns and create the import-job but when I execute the job simply nothing happens I'm only thrown back to the import page.
The only error shown by firebug is:
[javascript]TypeError: $.browser is undefined
http://xxx/uploads/tx_t3jquery/jquery-1.9.x-1.10.x-1.2.x.js?1399481181
Line 23308[/javascript]

I tried converting the file to xml and Excel97 xls but both produces php errors when I try uploading the file.
XML:
PHP
Fatal error: Class 'xml2Array' not found in /www/htdocs/v163506/neu/typo3conf/ext/multishop/scripts/admin_pages/admin_import.php on line 397


XLS:
PHP
Fatal error: require_once(): Failed opening required '/www/htdocs/v163506/neu/typo3conf/ext/phpexcel_service/Classes/PHPExcel/IOFactory.php' (include_path='/www/htdocs/v163506/neu/typo3/contrib/pear/:.:/usr/share/php:..') in /www/htdocs/v163506/neu/typo3conf/ext/multishop/scripts/admin_pages/admin_import.php on line 364


I'm working with latest Multishop V3 and Typo3 6.2.2

All errors are the same in Firefox and Chromium.

any hints would be appreciated.
Written on: 09. 05. 2014 [15:57]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Multishop 3 requires jQuery 2. You are using 1.9.

Also you must enable the module: Migrate in the t3jquery settings, cause $.browser is removed in jQuery 2.

I think your phpexcel plugin does not yet downloaded the library. Go to the extension manager, run the import script in phpexcel.

The xml2array error is because your PHP is not compiled with SimpleXML. You should install php-xml module.

Also install the official version of Multishop 3.0.1. It will be on TER tonight.
Written on: 23. 06. 2014 [15:11]