• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

No products listed in FE


Author Message
tzaman
Tomaž Zaman
Multishop newbie
Topic creator
registered since: 31.03.2011
Posts: 1
Hey, first I want to thank you for a what it looks like a great extension but I have a problem: I can add a product fine, but if I want to upload an image with that product, nothing happens, the modal window becomes blank (black) and that's it.
I can add a product without an image, and I can see it in the database, but when i try to find it in the 'products' page i get no result. What could be wrong? I have the latest version of TYPO3 and multishop.

Thank you

PS: One question, do you plan to use templates in the future, I like to be in control and at this moment the basket has div tags echoed from PHP...

[This article was edited 1 times, at last 31.03.2011 at 14:04.]
Written on: 31. 03. 2011 [14:03]
seaheritage
Steven Robinson
Multishop newbie
registered since: 19.06.2011
Posts: 1
A pretty late reply, but -
I have the same problem. I can see what should have appeared on the black screen by using click-drag from the bottom of the black screen to the top (and NOT the other way). It then shows an error message.

The error message in my case refers to a php file - "Fatal error Class't3lib_utility_Command' not found in /home/heritage/publick_html/typo3conf/ext/multishop/pi1/classes/class.mslib_befe.php on line 128" (also on line 196 with category images). When I looked inside that, the problem might be with imageMagick, not with Multishop. I'm looking into that.

But I haven't solved why the message does not appear without click-drag. Perhaps that is imageMagick also.
Written on: 25. 06. 2011 [06:18]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
In the latest version (1.0.17) we have changed the way of resizing images to a more compatible way. Could you confirm that image resizing works 100% in that version? (of course ImageMagick or GraphicsMagick must be installed on your server).

If you'd like to customize some specific sections (like the basket), just add a new content element to the page that contains the plugin Multishop and configure the flexform like this:

miscelenous / custom script
Custom script path: fileadmin/my_custom_scripts/basket (no .php at the end)

That way you could add your own PHP scripts and your script has all the methods of mslib_fe (front-end class) and mslib_befe (back-end front-end class) available.

This approach gives you the power to not downgrade your custom work when installing a new Multishop update.

Hope it helps.

Cheers,

Bas van Beek
Written on: 26. 06. 2011 [18:30]