• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Ultrasearch value for "options attributes filter" ?


Author Message
junfan
Christophe
Multishop professional
Topic creator
registered since: 16.08.2013
Posts: 38
Hello,

Which value use to setup "options attributes" filter in the ultrasearch setup ? This to have a filter as in the Bas van Beek's attachement exemple here :
[url=]https://www.typo3multishop.com/forum/list_post/filtering-by-attributes-16/?tx_mmforum_pi1[sword]=ultrasearch%20specification%20filter#pid26[/url]

I searched into every php files of multishop, but i can't find...

And i don't understand how to make a query in the ultrasearch.php file, because in the tx_multishop_products_flat table there isn't any options_id or products_attributes_id field...


Someone here to help me please ?! banghead.gif icon_eek.gif
Written on: 24. 08. 2013 [16:10]
junfan
Christophe
Multishop professional
Topic creator
registered since: 16.08.2013
Posts: 38
Ok i understood...

This solve this topic too :https://www.typo3multishop.com/forum/list_post/ultrasearch-setup-587/

To display the attributes filter you must add "all" in the setup line, in the flexform.

So for example : [typoscript]sort_filter:list;;all;categories:checkbox[/typoscript]

In fact, "all" display attributes filter AND price_filter only.
Written on: 26. 08. 2013 [20:14]