• My account
    • (X)Sign in

      I am a returning customer at TYPO3 Multishop

      Enter your username and password here in order to log in on the website:

      Forgot your password?

      Not yet customer of TYPO3 Multishop?

      • Order history
      • Automatic generated e-mail history
      • Track your Order
      New at TYPO3 Multishop
You are here:

Help by translating Multishop in your local language

On the following page you can help by translating Multishop in your local language:

https://translation.typo3.org/projects/TYPO3.ext.multishop/

Spanish:

https://translation.typo3.org/es/TYPO3.ext.multishop/pi1/locallang.xlf

The following language are already translated by our supporters:

  • Dutch
  • German
  • French

Upgrade typo3_multishop v.2.0.1


Author Message
cindy
Cindy
Multishop experienced
Topic creator
registered since: 07.09.2011
Posts: 24
Hi,

I had the version 1.0.38 of typo3_multishop and I make the upgrade, now I have the version 2.0.1.

I have a little problem. In the page Roadmap, there is a notice:
Upgrade notices: If you are upgrading from 1.x.x to 2.0.0 you need to reset the constant "plugin.multishop.admin_template_folder" to it's default value which is: EXT:multishop/templates/admin_multishop.

I make that, but my admin interface isn't beautiful (missing style, image). I emptied cache, but it isn't work.

Can you help me ?

Thank you very much
Best regards,
Cindy
Written on: 18. 11. 2011 [12:32]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
see screenshot.

Also you have to open SYSTEM / SYSTEM / COMPARE DATABASE, so it checks if all new modules are in your database.
Attachment

Written on: 18. 11. 2011 [19:47]
cindy
Cindy
Multishop experienced
Topic creator
registered since: 07.09.2011
Posts: 24
Hi,

Thank you for your response.

I always have the same problem.

In my multishop's configuration, I have :
Admin template skin
[plugin.multishop.admin_template_folder]
Folder of the admin template. Example: EXT:multishop/templates/admin_multishop.
EXT:multishop/templates/admin_multishop

I always have my style's problem.

For my database, I have errors. But I can't fix that. My tables are empty, so I deleted my two tables with the problem, but when TYPO3 created them, I always the same errors (see file).

I installed a new multishop on a another domain and I have the same problem with my database.

How can I fix that ?

Thank you very much,
Cindy


[This article was edited 1 times, at last 21.11.2011 at 13:28.]
Attachment

Written on: 21. 11. 2011 [13:27]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Could you contact us on Skype so we can investigate it better. The username is: typo3multishop.
Written on: 08. 12. 2011 [00:36]
leon
levent
Multishop experienced
registered since: 01.08.2011
Posts: 19
Hi,
I also upgraded from 1.03 to 2.20 from extension manager, but i can't see frontend admin area anymore. Only see the edit and delete icons on the products images. So i can't make SYSTEM->
update multishop procedure.
Written on: 05. 02. 2012 [15:30]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Update 1.x to 2.x requires several manual changes. The way we load the admin panel has been changed.

You can read this here:

Upgrade notices: If you are upgrading from 1.x.x to 2.0.0 you need to reset the constant "plugin.multishop.admin_template_folder" to it's default value which is: EXT:multishop/templates/admin_multishop.

http://www.typo3multishop.com/roadmap/typo3-multishop-updates/200/products_detail/
Written on: 10. 02. 2012 [19:31]
leon
levent
Multishop experienced
registered since: 01.08.2011
Posts: 19
I already controlled that constant but it had already the value: EXT:multishop/templates/admin_multishop. But still i can't see the admin panel. I also can't see the error messages whenever i clicked a form without filling it as a customer. Sorry i didn't read the installation, because i was upgrading but i have noticed the other steps now. Unfortunately when i click the "create jquery library" button, i see a blank page and nothing happens. This is the problem for me i think.
Edit2: It created the jquery files, but still the same problem(admin panel issue).

[This article was edited 2 times, at last 10.02.2012 at 21:11.]
Written on: 10. 02. 2012 [19:49]
leon
levent
Multishop experienced
registered since: 01.08.2011
Posts: 19
Ok i fixed the problem. It was because of my including the jquery library manually in my template file. Thank you Bas. And a last question, i upgraded from ext manager but i can't see an update multishop option in the admin panel. Is there a change?
Written on: 10. 02. 2012 [21:22]
bas
Bas van Beek
Multishop guru
registered since: 12.05.2010
Posts: 644
Wonderful..

2.0.21 has not yet been published. The version will be available in about 4 hours.
Written on: 10. 02. 2012 [21:44]